Web Content Display

MIDI input

MIDI (short for Musical Instrument Digital Interface) is a technical standard describing a protocol, digital interface and connectors and allows a wide variety of electronic musical instruments, computers and other related devices to connect and communicate with one another.

scorio allows to enter notes directly via a MIDI device or record notes to a metronome click. Either use a browser supporting the Web MIDI API, such as Google Chrome, or you need to install the free Jazz plugin on your computer.

In the Internet you will find numerous collections of pieces in MIDI format which you can import, edit, and print with scorio. The MIDI import can be used without installing the Jazz plugin.

At present the MIDI functions can not be used in the iPad app.


Activating MIDI input

Perform the following steps to activate note entry via a MIDI keyboard:

  • Use a browser supporting the Web MIDI API, such as Google Chrome


  • Install the Jazz plugin on your computer (currently available for Windows and Mac OS X). You may connect the MIDI keyboard to the computer and check on the following MIDI input site whether MIDI input works.

Now open the scorio note editor. The active MIDI input device should be recognized automatically. The status of recognized MIDI input and output devices is displayed as green or red symbols on the right side of the mouse keyboard.

If the MIDI input device is not recognized or if you want to select another input device from several MIDI devices, you can do that with the dialog "MIDI settings" in the "Tools" menu.


Enter MIDI notes directly

After successful activation of MIDI input you can enter single notes or chords with a fixed duration via the MIDI keyboard. Start with selecting a note after which the notes should be inserted. The duration of notes to be inserted can be selected in the toolbar. Use the following shortcuts to change the note duration in the toolbar: 1 = whole, 2 = half, 3 = 32nd, 4 = quarter, 6 = 16th, 8 = eighth, . = change dots.


Enter MIDI notes rhythmically (scorio Pro and scorio Unlimited)

Use the dialog "Record MIDI" in the "Tools" menu if you want to enter several notes with different durations at once into a voice. Click "Start" to start the metronome for recording. The recording begins with the first note entered on the MIDI keyboard. After recording click "Stop". Confirm MIDI input with OK or click "Start" to start a new recording.

The recording offers the following settings:

  • Play back while recording: Only use this option if you have a mute MIDI keyboard without sound generation. Because of the MIDI processing the sound is played with a short delay which may disturb during recording.
  • Quarter beats per minute: Enter the metronome speed here.
  • Remove rests smaller than: During recording notes are normally shortened slightly when changing from one note to another or to avoid overlapping notes. Use this option to remove rests shorter than the selected rest duration during recording.
  • Remove overlapping notes: When entering chords or polyphonic sections often overlapping tied notes are created. Check this option to remove overlapping notes and reduce the number of ties.


Import MIDI files (scorio Pro and scorio Unlimited)

If you already have a file in MIDI format (*.mid or *.midi) you can import it with the dialog "Import/MIDI" in the "File" menu.

The MIDI import has the following settings:

  • Create new staves for staves with multiple voices: Sometimes MIDI files are structured in a way that several voices (channels) are included within one MIDI staff (track). Check this option to notate each of these voices in its own staff.
  • Remove rests smaller than: see above (default: 32nd rest)
  • Remove overlapping notes: see above (default: do not remove notes)
  • Maximum number of measures: If you try various settings it is recommended not to import the entire MIDI file but only a certain number of measures that can specified here. scorio Basic users may import 8 measures only.

Hint: MIDI files differ in the fact that note durations either correspond to the recorded values or they are adjusted to the notated durations (quantization). scorio determines automatically whether a given MIDI file is quantized or not. For quantized files it is recommended to keep the default settings for the removal of rests and overlapping notes. For unquantized files you should try various settings and keep the result with the best note recognition.